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A következő oldalon lévő ábrán az MPLAB egy menüképe látható. 

A most következő összefoglalás nem helyettesíti a kézikönyvet, és nem törekszik a teljességre. A menükkel 
való ismerkedésnek a legjobb módja azok kipróbálása. Feltételezzük továbbá, hogy az olvasó jártas a Windows 
alapú környezet használatában. 

Az ilyen, „mindent az egyben” típusú programot szokták integrált fejlesztőkörnyezetnek (Integrated Developping 
Enviroment – IDE) is nevezni. 

Az MPLAB parancsainak kiadására három lehetőségünk van: 
• a menürendszerből választjuk ki, 
• a hozzájuk rendelt billentyűkombinációt használjuk, 
• az eszköztár megfelelő ikonjára kattintva aktivizáljuk. 

 
Az MPLAB-bal végzett munkával kapcsolatban először két fontos fogalommal kell megismerkednünk: a projekttel, 

illetve a munkakörnyezettel (workspace).  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Új forrásfájl készítése. 
Meglévő forrásfájl megnyitása. 
Bezárás 
 
Mentés  
Mentés más néven 
Az összes megnyitott fájl mentése  
 
Munkakörnyezet megnyitása 
Munkakörnyezet mentése 
Munkakörnyezet mentése más néven 
Munkakörnyezet bezárása 
 
HEX kiterjesztésű fájlt tudunk behívni  
HEX fájl mentése 
 
Kiválasztott fájl nyomtatása 
 
Az utoljára használt fájlok, illetve munkakörnyezet leíró 
fájlok listája van a menüpont végén. 
Kilépés az MPLAB-ból 
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A projekt koncepció azt jelenti, hogy az adott fejlesztéshez tartozó fájlokat egy ún. projektfájlban tartjuk nyilván. 
Ha ezt a fájlt megnyitjuk, a nyilvántartott fájlok a fejlesztéskor azonnal betöltődnek és használhatók.  
A Project menüvel lehet a projekteket kezelni.  

A munkakörnyezet a kiválasztott mikrokontrollerről, a debug, illetve programozó eszközökről, a megnyitott 
ablakokról, és azok helyéről és egyéb IDE beállításokról hordoz információt. 

Installálás után legördülő menüket tartalmazó menürendszer jelenik meg, amelynek első eleme a  File 
menüpont: 

AZ MPLAB SZÖVEGSZERKESZTŐJE (EDIT MENÜ) 
A szövegszerkesztés karakterekkel (és az ezekből képzett, bonyolultabb szövegobjektumokkal) végzett műveletek 
összessége. A leggyakoribb műveletek: 

Kijelölés (selection). Kijelöljük azt a szövegrészt, amely a következő műveletben majd részt vesz. A 
kijelölt objektum lehet karakter, sor vagy logikailag osztályozva szó, mondat, bekezdés. A kijelölés alatt 
egy szövegobjektum kiválasztását értjük. 

Beillesztés (insert). Egy szövegobjektum beillesztése egy megadott helyre (pl. maga a begépelés). 
Törlés (delete). A már előzőleg kijelölt objektumokkal végezhetjük el. Törlés esetén az objektum eltűnik a 

dokumentumból. 
Másolás (copy). A kijelölt rész a másolás hatására egy másik (általunk kiválasztott) helyen ismételten 

megjelenik. 
Mozgatás (move). A kijelölt rész az adott helyről átkerül az általunk kiválasztott új helyre. 

 
Az Edit menü az MPLAB szövegszerkesztőjéhez kapcsolódik. Az MPLAB szövegszerkesztője lényegében egy 

átlagos, Windows alapú szövegszerkesztő, de olyan részekkel lett kiegészítve, amelyek a programok megírását 
megkönnyítik. 

 
Undo Ctrl+Z Utolsó szerkesztő művelet visszavonása. 
Redo                       
Ctrl+Z 

Utolsó szerkesztő művelet megismétlése 

Cut  Ctrl + X Kijelölt rész kivágása és a vágólapra másolása. 
Copy Ctrl + C Kijelölt rész vágólapra másolása. 
Paste  Ctrl + V A kurzorral megjelölt helyre másoljuk a vágólap 

tartalmát. 
Delete  Del  Kijelölt rész törlése. 
Select All                  Ctrl + 
A 

A teljes szöveg kijelölése. 

Find...  Ctrl + F Keresés. 
Find Next.  F3 Keresés a következőre. 
Replace...                  Ctrl + 
H 

Keresés és helyettesítés. 

Go To...  Ctrl + G Ugrás adott sorszámú sorra. 
Match Brace  Ctrl + M Ha a kezdő zárójelre állunk a kurzorral, akkor a 

parancs segítségével megkereshetjük a hozzá 
tartozó befejező zárójelet. 

Properties… A szöveg jellemzőit: nagyságot, szint, karakter 
típust, tabulátor hosszt stb. állíthatunk be itt.  

 
Fontos megjegyezni, hogy a program egyes jellemzőinek megjelenítése színes szöveggel történik, így jól 
megkülönböztethetők az utasítások, azok paraméterei, megjegyzések, illetve az assembler direktívák. 

VIEW MENÜ 
A menüpontban kiválaszthatjuk azokat az ablakokat 
amelyek tartalmát a fejlesztés során látni szeretnénk. 

A Project menüpont választásával láthatjuk a 
projekthez tartozó fájlokat. 

Az Output menüpont aktivizálásakor a  fordító 
program (pl. az assembler) futásának az eredményét 
látjuk. 

A többi menüpont aktivizálásával a megfelelő 
adatcsoportot jeleníthetjük meg egy ablakban.  
 

WATCH ablak 
Ezek közül külön megemlítjük a Watch (néző) ablakot. A program regisztereinek 

futás közbeni megfigyelésére az Add SFR vagy az Add Symbol gombok 
segítségével lehet a mikrovezérlő SFR, illetve felhasználói regisztereit kiválasztani, 
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és tartalmukat megjeleníteni, illetve módosítani. A watch ablakra jobb egérgombbal kattintva egy menü jelenik meg, 
aminek segítségével a watch ablakok menthetők, átnevezhetők, törölhetők, illetve betölthetők. Az ablakban lévő 
regiszterek tartalma fájlba menthető, illetve kinyomtatható. Egy projekthez egyidőben maximum négy watch ablak 
is választható. 

A Properties… menüben állíthatjuk be, hogy a regiszter értékét milyen formában (decimális, hexa, bináris, 
ASCII) kívánjuk megjeleníteni. 

 
FONTOS!  
A WATCH ablakban elhelyezett regiszterek tartalmának vizsgálatával tudjuk a programunk helyes 

működését ellenőrizni.  
 
A következő ábrán összefoglaltuk a megjeleníthető adatcsoportok ablakait. 

 
PROJECT MENÜ 

Két fogalmat, a projekt, illetve munkakörnyezet fogalmát már 
ismertettük. A leggyakoribb esetekben egy munkakörnyezethez egy 
projekt tartozik, de több projekt is használható egy munkakörnyezetben. 
Ezek alapján lehetséges:  

egy assembly fájl használata (Quickbuild),  
egy projekt használata egy munkakörnyezetben – ez a MPLAB 

IDE v5.xx programnál használt kialakítás, 
több projekt használata egy munkakörnyezetben. 

 
Fontos tudnunk, hogy az MPLAB 6.xx verzióban először mindig 

az eszközt, vagyis a mikrokontrollert választjuk ki a 
Configure>Select Device menüpontban. 

 
Az MPLAB-ben a 

projekt egy 
projektobjektum (ez a 
node, azaz csomópont) egy vagy több forrásobjektumból (node-
ból) épül fel. Ezek a források általában MPASM assembler, 
illetve magas szintű C vagy BASIC forrásfájlok, előre lefordított 
könyvtárfájlok, más tárgykódok (object fájlok), illetve az ezek 
összekapcsolását végző linker script vezérlő szövegfájlok 
(hasonlók a DOS batch fájljaihoz).  

Általában ugyanabban a könyvtárban helyezzük el a 
projektet, mint a forrásfájlokat. Linkeléskor az összelinkelni 
kívánt ún. object fájlokból hozzuk létre a végleges lefordított 
tárgykódot, vagyis .HEX fájlt ilyen node-ok építik fel. Egy node 
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egy forrásprogramot és egy fordítóprogramot (BASIC, C) vagy assembler programot is meghatároz, ezeket hívjuk 
nyelvi eszközöknek (Language Tool – nyelvi eszköz). 

A Project menü New, Open, Close pontjainak jelentése nyilvánvaló: projekt 
létrehozása, meglévő megnyitása, illetve az aktív projekt bezárása. 
Set Active Project: több megnyitott projekt esetén kiválaszthatjuk az éppen 
használtat. 
QUICKBUILD használata 

A legtöbb esetben a fejlesztés egyetlen assembler programot tartalmaz. Ilyenkor a 
projekt létrehozása helyett a gyorsabb megoldást biztosító Quickbuild fejlesztő módot 
használjuk.  

Először kiválasztjuk a fejlesztéshez használt kontrollert: Configure>Select Device. 
Ellenőrizzük, hogy a Quickbuild mód aktív: (Project>Set Active Project>None (Quickbuild mode)). Vagy létrehozzuk 
az assembler fájlt (File>New), vagy egy létezőt töltünk be (File>Open). Assembláláshoz kiválasztjuk a 
Project>Quickbuild file.asm  menüpontot, ahol file.asm az aktív fájl neve. 

Ezek után már lehet a programban hibát keresni, vagy a szimulátorban futtatni. A munka befejezésekor a 
munkakörnyezet megadott néven elmenthető: File>Save Workspace, illetve újbóli használatkor betölthető: 
File>Open Workspace. 
 
Egy projekt  egy munkakörnyezetben 

Mi a továbbiakban (mivel ez a leírás az MPLAB-bel ismerke-
dőknek szól), csupán az MPLAB IDE v5.xx programnál megszokott 
projekt létrehozásának lépéseit írjuk le. A gyakorlatban is ez a 
legtöbbször előforduló eset. Ilyenkor a munkakörnyezet beállítása 
nem szükséges. Ezt az üzemmódot a Configure>Settings>Projects 
fülön állíthatjuk be: Use one-to-one project-workpace model. Utána: 

Először kiválasztjuk a fejlesztéshez használt 
kontrollert: Configure>Select Device. 

Létrehozzuk a projektet, és beillesztjük a fájlokat: Project>Add Files to Project… 
Létrehozzuk a tárgykódot tartalmazó fájlt: Project>Build All. Ha csak a megváltozott fájlokat akarjuk újra fordítani, 

akkor a Project>Make  menüpontot aktivizáljuk. 
 
Foglaljuk össze a további menüpontok jelentését: 
Project>Clean menüpontban a projekt létrehozása során keletkezett fájlokat törölhetjük ki. 
Project>Build All menüpontot aktualizálva a projekt újrafordítása történik meg. (Ilyenkor a szimbólumokat 

tartalmazó .COD kiterjesztésű fájl létrehozási időpontját hasonlítja a projekt .INC és 
.ASM kiterjesztésű fájljaihoz. Ha a .COD régebbi, mint a hasonlított fájlok 
valamelyike [valószínűleg módosítva lett], akkor elvégzi az újrafordítást.) 

Project>Build Options… menüpontra kattintva megadhatjuk a projektben 
szereplő fájlok útvonalát, azaz a könyvtárakat. 

Project>Save Project a projekt mentése. 
Project>Add Files to Project… a menüpont segítségével tudjuk a projektbe a 

szükséges (pl. :ASM) fájlokat beilleszteni. 
Project>Remove File From Project a menüpont segítségével tudjuk a projektből 

fájlokat eltávolítani. 
Project>Select Language Toolsuits, illetve a Project>Set Language Tool Locations… menüpontok segítségével 

új fordítót (pl. C, BASIC) illeszthetünk az MPLAB környezetébe. 

AZ MPLAB SZIMULÁTORA 
A Debugger>Select_Tool>MPLAB_SIM kiválasztásakor aktivizált 

szimulátorprogram arra szolgál, hogy a PIC mikrokontrollerekre írt programot 
ellenőrzött módon lehessen végrehajtani. Ez azt jelenti, hogy a program végrehajtása 
közben: 
• meg tudjuk vizsgálni és esetleg módosítani a kontroller bármelyik regiszterének 

tartalmát (watch),  
• adott helyen meg tudjuk állítani a program futását, azaz töréspontot tudjunk 

elhelyezni (breakpoint), 
• tudjuk a programot lépésenként futtatni (single step), 
• a külső környezetből jövő (input) adatokat 

fájlból beolvasva szimulálni (stimulus), 
• illetve kiküldött (output) adatokat fájlba eltárolni, 
• a szimuláció során bekövetkező eseményeket a későbbi elemzés céljából gyűjteni 

(trace). 
A szimulátor csupán egy a hibakeresést és tesztelést lehetővé tévő eszközök 

közül. A Select Tool aktivizálásával választhatjuk még az ICD2 debuggert, illetve több emulátor típust.  
A Debugger>Clear All Memory menüpont segítségével a szimulátor minden memóriáját töröljük (0-val töltjük 
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fel). A további menüpontok: 

Run F9 A program futtatása. 
Halt F5 A futó program megállítása, programszámláló 

megáll. 
Step Into F7 Lépésenkénti programvégrehajtás. 
Step Over F8 Lépésenkénti futtatás, a rutinokat egy lépésben 

hajtja végre. 
Reset  Alaphelyzetbe állítás, programszámlálóba nulla 

kerül. 

Debugger>Breakpoints… A felhasználónak a program belövése során igen nagy segítséget nyújt, ha a 
programot egy, még az indítás előtt kijelölt címeken meg lehet állítani, azaz a futását felfüggeszteni. Ekkor ugyanis 
a regiszterek és a programban használt változók tartalmainak vizsgálatával könnyen eldönthet ő, hogy a program 
eddig a pontig helyesen vagy hibásan működött. A teljes programot több, logikailag jól elhatárolt részre bontva, a 
hibásan működő programrész gyorsan meghatározható. Ilyen leállási feltétel – azaz töréspont (breakpoint) – a 
programban több is elhelyezhető. 

Az is fontos lehet, hogy egy program szimulálása közben a futás során a használt regiszterekről, azok 
tartalmáról adatokat gyűjtsünk. Ez a nyomkövetés vagy más néven tracing. 

 
Szimulátor használatakor alkalmazhatunk a programunknál nyomkövetést. A Trace ablak 

Debugger>Settings>Trace/Pins menüjében engedélyezhetjük a nyomkövetést. A nyomkövetés eredménye a Trace 
ablakban látható, ahol az oszlopok feliratai a következőket jelentik: 
Line  - sorszám a nyomkövetés kezdetétől.  
Addr  - az utasítás programcíme 
Op  - az utasítás numerikus kódja 
Label  - az utasítás cimkéje 
Instruction  - az utasítás visszafordított mnemonikja 
SA  - forráscím 
SD  - forrásadat 
DA  - célcím 
DD  - céladat  
Cycles  - az eltelt ciklusok száma. 
 

A lépésenkénti programvégrehajtás (Step Into, Step Over) 
üzemmódban a felhasználói programnak mindig csak egy utasítása 
hajtódik végre, és ilyenkor mindig lehetőség van a regiszterek vagy a 
tártartalmak vizsgálatára, vagyis a végrehajtott utasítás hatásának, a 
program helyes működésének az ellenőrzésére.  

 
A stopperórával (Stowatch) programrészletek időbeli végrehajtását 

követhetjük nyomon. Megadhatjuk a szimulált processzor órajelét 
(Processor Frequency). A Zero gombbal nullázhatjuk a stoppert. 
Kijelzi a nullázás óta végrehajtott ciklusok számát (Instruction Cycles 
– a legtöbb esetben egy utasítás egy ciklus), illetve az eltelt időt (Time). 
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Választható, hogy a stopper RESET-kor törlődjön. 
 

A külvilág figyelembe vétele: a gerjesztések (stimulusok) 
A szimuláció során a legnehezebb feladat a külső környezet figyelembe vétele. A külvilággal való kapcsolat 

szimulációjának megvalósítására az MPLAB két lehetőséget is felkínál:  
• a processzor lábaira adhatunk jelet (Pin stimulus),  
• illetve a program futásakor a végrehajtott ciklusszám, illetve az utasításszámláló (PC) adott értékének 

elérésekor generált trigger feltétel teljesülése esetén agy adott regiszterbe megadott érték kerül (File 
stimulus). 

 
A lábakra adható gerjesztések: Pin stimulus 

 
Az Add Row jelű gombra kattintva adhatunk meg új lábgerjesztést. A Load és Save gombokkal menthetjük el, 

illetve tölthetjük be a kész pin stimulus állományt.  
A külvilágot egy lábon kétféle módon szimulálhatjuk: szinkron (clock) stimulus alkalmazásakor egy I/O lábhoz 

(Pin) ismétlődő periodikus négyszögjelet (clock) rendelünk: meg kell adni, hogy hány ciklusig legyen a láb állapota 
magas (high cycles), és hány ciklusig alacsony (low cycles) szintű. A ciklusszámot decimális számként kell 
megadni. Az Invert bejelölésével a jel ellentétes lesz (alacsonnyal kezd).  

Aszinkron stimulus segítségével a szimulált kontroller lábaihoz gerjesztéseket rendelünk, és ezeket a 
képernyőn lévő nyomógomb (Fire) segítségével aktivizálhatjuk. A stimulushoz hozzá kell rendelnünk a lábat (Pin) 
és a gerjesztés típusát (Action): 
Low – a gomb megnyomásakor alacsony szint lesz az adott lábon; 
High – a gomb megnyomásakor magas szint lesz az adott lábon; 
Toggle – a gomb megnyomásakor az adott lábon lévő szint ellentétére vált; 
Pulse – a gomb megnyomásakor egy impulzus jelenik meg az adott lábon. 
 
Regisztertartalmak megadása futáskor: File stimulus 

 
Fájl stimulus esetén egyedi gerjesztéseket tartalmazó szinkron stimulus fájlok listáját használjuk, vagyis 

egyszerre több gerjesztés lehet aktív. Az Input Files területen lévő Add, Remove, Edit, Save, Cancel gombokkal 
kezelhetjük ezeket a fájlokat. A listában szereplő szinkron stimulus fájl megszerkesztése az Edit gombra 
kattintással lehetséges.  

A gerjesztés aktivázálási feltételét a Trigger On oszlopban lehet megadni, ez lehet Cycles – vagyis a RESET 
utáni hányadik utasítás ciklus után aktivizálódjon a gerjesztés, vagy PC azaz az utasításszámláló egy adott értéke. 

Trig Value oszlopba kell írni a ciklusszámot, vagy a PC értékét. 
Repeat jelölése esetén a megadott cikluszám határozza meg a ciklikus gerjesztés ismétlődését 
Pin/Register oszlopban egy legördülő listából választhatjuk ki a gerjesztést kapó lábat, 

illetve azt a regisztert amelybe értéket egy register stimulus fájlból jutattunk.  
Value: a beküldött érték: ez 0 vagy 1 láb (Pin) gerjesztés esetén. Register gerjesztés 

esetén vagy egy hexadecimális érték, illetve egy register stimulus fájl megadása.   
Register Stimulus: amikor a szimulációban megadott címre érünk, megadott 

regiszterbe egy szövegfájlból adott értéket töltünk. Ha többször haladunk át az adott címen, 
akkor a fájlban szereplő egymás utáni értékek sorban egymás után betöltődnek a 
regiszterbe. Csak Trigger On=PC esetén használható! 

PICSTART PLUS PROGRAMOZÓ 
A Picstart Plus programozó segítségével tudjuk a fejlesztett programjainkat EPROM-os 

vagy OTP-s tokba írni, és a valódi hardverkörnyezetben kipróbálni. A programozó minden 
PIC kontroller írására képes, az újabb típusok megjelenésekor az MCHIP adja azt a .HEX 
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kiterjesztésű fájlt, amelyet egy PIC17C44-es tokba írva a programozó aktualizálható (upgrade).  
A programozót a számítógép valamelyik soros vonalára kell csatlakoztatni. A programozás során az MPLAB 

belső memóriapufferének tartalmát írjuk a programozóban lévő tokba, a beállított konfigurációs bitekkel együtt.  
A puffert vagy egy fájlból töltjük fel: (File>Import) vagy az assemblálás során keletkezik. A programozóval 

pufferbe beolvasott PIC tok tartalmát fájlba is menthetjük: (File>Export)  
Enable Programmer: a programozó engedélyezése. 
Disable Programmer: a programozó tiltása. 
Program: programozás. 
Verify: a beírt program ellenőrzése. 
Read: a programozóba helyezett PIC tok olvasása. 
Blank Check All: a tok ürességének (memória + konfigurációs bitek) vizsgálata. 
Blank Check OTP : OTP tok ürességének vizsgálata. 
Reset: a programozó alaphelyzetbe állítása. 
Reset Program Statistics: a programozáskor gyűjtött adatok törlése. 
Erase Flash Device: a flash eszköz törlése. 
About: a programozóról… 
Settings: programozandó memóriatartományok, kommunikáció. 

CONFIGURE MENÜ 
A munka kezdetekor ezt a menüpontot kell aktivizálni, és a Select Device… 

menüpontban kell a használt mikrovezérlőt kiválasztani. 
A Configuration Bits… menüpontban lehet a konfigurációs biteket beállítani, ha a 

programban a CONFIG direktíva segítségével ezt nem tettük meg. 
External Memory külső memóriát tartalmazó eszközök esetén állíthatók be a 

paraméterek. 
ID Memory… a tokba írható egyedi azonosító ID értéke adható meg. 
Settings… Munkaterület, program betöltési és projekt paraméterek adhatók meg itt. 
 

 
 
 AZ ICD2 KEZELÉSE 

Ha az ICD2-t használjuk, akkor a Debugger>Tools menüpontban az 
MPLAB ICD2 menüpontot kell választani. Természetesen először a 
debuggert soros vagy USB porton kell csatlakoztatni, majd soros 
kommunikáció esetén a megfelelő COM portot és adatátviteli sebességet 
(pl. 19200) is be kell állítani. Az USB használata a port installálását 
igényli. A Debugger>Settings… menüpontban az ICD2 paramétereit 
állíthatjuk be. 

WINDOW MENÜ 
A WINDOW menüpontok 

Windows környezetben 
megszokottak. 

HELP MENÜ 
Az egyik legnagyobb 

erénye a MPLAB-nak az 
igen részletes és bőséges (igaz, angol nyelvű) segítség. Az itt található 
leírások hipertext jellegűek, azaz linkek vannak elhelyezve, amire 
kattintva eljuthatunk egy másik információhoz. 

Lényegében minden információt tartalmaz a programról, külön 
szerepeltetve az MPLAB egyes komponenseit. Az egyes súgók a jobb 
eligazodást segítendő tematikus módon alfejezetekre vannak osztva. 

ÖSSZEFOGLALÁS 
Foglaljuk össze, hogyan kell használnunk az MPLAB-ot programjaink fejlesztésére. Első lépésként kiválasztjuk a 
megfelelő PIC-típust. (Configure > Select device), ha még nincs projektünk, a File > New menüpontjával 
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létrehozhatunk egy új forrásfájlt. Másik, és valószínűleg jobb megoldás az, 
hogy a létrehozott új projektünkbe egy átnevezett .ASM fájlt illesztünk, mert 
azt könnyen módosíthatjuk a közös, szabványos részek meghagyásával. Ha 
szükséges, a projektbe INCLUDE fájlokat is beilleszthetünk. 

Elmentés után a fájlokat a Project > Quickbuild menüpont segítségével 
lefordítjuk, az esetleges hibákat kijavítjuk. Ehhez az is segítséget nyújt, 
hogy a hibafájl megjelenítésekor rákattintva egérgombbal a kurzorral 
mutatott hibás sorra, a forrásprogram megfelelő sora jelenik meg a 
szerkesztőben. 

A fájl futtatása a megfelelő debugger menüpont segítségével végezhető. 
Beállíthatók töréspontok, nyomkövetés, és gerjesztések (stimulusok) 
segítségével a külső környezetet is szimulálhatjuk. A Watch ablak 
felhasználásával a futás során fontos regisztereket is figyelemmel 
kísérhetjük. 

Fontos! A megfelelő működéshez a processzor típusát a 
forrásszövegben megadott típushoz azonos módon kötelező megadni! 

Egy ilyen összetett eszköz, mint az MPLAB kezelése, használatának elsajátítása, szorgalmas munkát igényel. 
A munkát jelentősen megkönnyíti az eszköztárak és a státuszsor felhasználása. A leírás nem tért ki az egér 
használatára, de célszerű mindkét egérgombot különböző szituációkban kipróbálni, mert számos funkció 
valósítható meg az egér segítségével. (Például töréspontok, nyomkövetés beállítása a forrásnyelvi szövegben 
kurzorral az adott részre mutatva és a jobb egérgombbal kattintva.) 

SZERSZÁMKÉSZLETEK (TOOLBARS) 

Edit Project Debug Program 
 

A fejlesztői környezet használatát nagyon megkönnyíti a felső sorban elhelyezett, egérkattintással aktivizálható 
„szerszámos polc” (toolbar). Bár az egérkurzort az egyes ikonokra pozicionálva megjelenik az ikonhoz tartozó 
funkció neve, de a következőkben a könnyebb használat érdekében ezeket összefoglaljuk. Négy csoport van:    

Edit Toolbar 
Project Toolbar 
Debug Toolbar 
Program Toolbar 

Edit Toolbar ikonjai: 
New File – Új fájl ablak megnyitása 
Open File – Egy létező fájl megnyitása az ablakban 
Save File – Az aktuális fájl mentése 
Cut – A kiválasztott szöveg kivágása és áthelyezése a vágólapra 
Copy - A kiválasztott szöveg átmásolása a vágólapra  
Paste - Szöveg bemásolása az aktuális kurzorpozicióra a vágólapról  
Print – Az aktív ablakban lévő fájl nyomtatása 
About – Információ az MPLAB IDE fejlesztői környezetről 

Project Toolbar ikonjai: 
New Project – Egy új projekt helyének és nevének megadása 
Open Project – Létező projekt megnyitása 
Save Workspace – Az aktuális projekt, és munkakörnyezetének mentése  
Build Options – A projekt beállításainak megnézése, vagy megváltoztatása 
Project Help – Projektekkel kapcsolatos segítség 
Make – Csak azokat a fájlokat dolgozza fel, amelyek megváltoztak 
Build All – Minden fájl feldolgozása 

Debug Toolbar ikonjai: 
Run – Program futtatása 
Halt – Program végrehajtásának megállítása 
Step Into – Következő utasítás végrehajtása 
Step Over – Szubrutin végrehajtása egy lépésben 
Reset - MCLR reset végrehajtása 

Program Toolbar ikonjai: 
Program – Kódmemória programozása a Programmer>Settings menüben beállítottak szerint. 
Read - Kódmemória kiolvasása a Programmer>Settings menüben beállítottak szerint. 
Verify – Programozás helyességének az ellenőrzése a Programmer>Settings, menüben beállítottak 

szerint. 
Megjegyzések: 

A leírás az MPLAB V6.10 verzió alapján készült. 
Egyes menüpontok kiválasztásakor újabb ikonok is megjelenhetnek. 


